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                                 Project System

Write Code R Support RStudio Pro Features

Debug Mode Version Control with Git or SVN

Package Writing

Système de projets

Ecrire du code Assistance R Caractéristiques RStudio Pro

Mode « Debug » Suivi de version avec Git ou SVN

Ecriture de package

Transformer le projet en package et 
activer la documentation par oxygen 
 Tools > Project Options > Build Tools

Documentation du package oxygen : 
Help > Roxygen Quick Reference

File > New Project >  
New Directory > R Package

en savoir plus sur www.rstudio.com

L’EDI RStudio est un Environnement de  Développement Intégré décliné en 3 versions :

EDI Bureau  
Une version locale de 
l’EDI pour votre bureau 

Serveur Open Source 
pour de plus grandes 
ressources de calcul et un 
accès distant

Serveur Professionnel  
pour les équipes qui partagent 
d’importantes ressources de calcul, 
de grands jeux de données et des 
environnements de travail 
uniformesTéléchargez-les sur  www.rstudio.com. Chaque version fournit la même version indispensable d’interface

Partager un projet  
avec des 
collaborateurs

Collaborateurs 
actifs

Choisir la 
version de 
R

Démarrer une nouvelle 
session R dans le projet 
courant 

Fermer la session R 
du projet courantJHT

RStudio enregistre l’historique, 
l’espace de travail ainsi que le 
répertoire de travail comme 
associé à un projet. Ils sont 
rechargés automatiquement à 
chaque réouverture du projet 

Nom du projet 
courant

View(<données>) ouvre une vue type « feuille de calcul »

Trier par 
valeur

Filtrer les lignes par 
valeur ou plage de 

Trouver 
une valeur

Le panneau de Visualisation affiche du contenu HTML (applications 
Shiny, rapports RMarkdown et visualisations interactives

Interrompre 
l’application Shiny

Publier sur shinyapps.io, 
rpubs, RSConnect, …

Rafraîchir

RStudio ouvre la documentation dans un panneau d’ Aide

Page d’accueil Chercher dans 
les fichiers d’aide

Chercher une 
documentation

Le gestionnaire de package liste les packages disponibles

Cocher pour charger le package avec 
library().Décocher pour détacher avec  
detach()

Supprimer le 
package de 
la librairie

Installer un 
package

Mettre à 
jour

Créer une librairie de packages 
reproductible pour le projet 

RStudio ouvre un graphe dans le panneau de Graphique 

Navigation 
dans les 
graphes 

Ouvrir dans 
une fenêtre

Export du 
graphe

Suppression du 
graphe courant

Suppression 
des graphes

Version du 
package 
installée

Variables 
présentes dans 
l’environnement 
d’exécution des 
commandes

Le mode debug s’ouvre avec debug(), browse(), ou un point d’arrêt. 
RStudio ouvre le mode debug  quand il rencontre un point d’arrêt lors 
de l’exécution du code.

Ouvrir la liste des commandes 
précédentes pour examiner 
celle à l’origine de l’erreur

Lancer le mode 
« debugger » 
depuis l’origine de 
l’erreur 

Cliquer à côté 
du n° de ligne 
pour ajouter/
supprimer un 
point d’arrêt

Sélectionner la 
fonction à débugger 
dans les commandes 
précédentes

La ligne 
surlignée 
monte où 
l’exécution 
s’est arrêtée

Exécute la commande 
dans l’environnement 
où elle s’est 
interrompue

Explorer le 
code, ligne à 
ligne

Entrer et sortir 
de la fonction à 
exécuter

Reprendre 
l’exécution Quitter le 

mode 
« debug »

Ouvrir des fichiers Shiny, R 
Markdown, knitr, Sweave, 
LaTeX, .Rd et plus dans le 
panneau Source

Vérifier 
l’orthographe

Renvoyer 
l’output

Choix du 
type 
d’output

Choix du 
chemin  de 
l’output

Insérer un 
morceau de 
code

Aller au 
précédent 
morceau 
de code

Aller au 
prochain  
morceau 
de code

Exécuter le 
code 
sélectionné

Publier sur 
serveur

Voir le plan 
du fichier

Paramétrer 
les options 
knitr

Exécuter ce 
morceau de 
code et tous les 
précédents

Exécuter ce 
morceau de 
code

Aller au 
morceau 
de code 
nommé

RStudio identifie les fichiers app.R, server.R, ui.R, 
et global.R comme appartenant à des applications 

Exécuter               
l’ application Choisir où 

visualiser 
l'application

Publier  sur 
shinyapps.io ou 
sur  serveur

Gérer les 
comptes de 
publication

Accéder au guide R Markdown :  
Help > Markdown Quick Reference

EDI RStudio Aide-mémoire 

RStudio® est une marque déposée de  RStudio, Inc.  •  CC BY RStudio •  info@rstudio.com  •  844-448-1212 • rstudio.com En savoir plus :  support.rstudio.com  •  RStudio IDE  0.99.832  •  Mise à jour : 01/16Plus d’aide-mémoires sur http://www.rstudio.com/resources/cheatsheets/

Fichier 
indexé : 

Montrer le 
fichier diff

Valider les 
fichiers indexés

Push/Pull  
vers le serveur Voir 

l’historique

branche 
courante

• Ajouté 
• Supprimé 
• Modifié 
• Renommé 
• Non suivi

Activer sur Tools > Project Options > Git/SVN

Ouvrir un interpréteur 
de commande

A

D

M

R

?

Chercher dans 
l'environnement

Coloration syntaxique 
basée sur l’extension du 
fichier

Diagnostic du code dans la marge. Passer le 
pointeur de la souris sur le symbole pour 
plus de details.

Complétion (Tab) des 
noms de fonctions, 
adresses, arguments…

Prise en charge mili-langage 
des portions de code

Ouvrir dans 
une nouvelle 
fenêtre

Sauver Rechercher 
et remplacer

Compiler un 
bloc-notes

Exécuter le 
code 
sélectionné

Ré-Exécuter le 
code précédent

Sourcer avec ou 
sans écho

Voir le 
plan du 
fichier

Aller à la fonction Changer le type de fichiers

Naviguer 
dans les 
onglets

Un explorateur de fichier lié au répertoire de travail. 
Cliquer sur un répertoire ou un fichier pour ouvrir

Adresses des répertoires affichés

Importer 
un 
fichier

Créer un 
dossier

Supprimer 
un fichier

Renommer un 
fichier

Changer 
de 
repertoire

Affichage des objets en 
mémoire selon leur type 
avec une brève description

Voir le code 
source de la 
fonction

Voir les 
données 
dans la 
visionneuse

Charger un 
espace de 
travail

Sauver 
l’espace de 
travail

Importer des 
données avec 
l’assistant

Supprimer 
tous les objets

Afficher les 
objets en liste ou 
en grille

Choisir les environnements à afficher à 
partir des environnements parents

Historique des  commandes 
précédentes à exécuter/
ajouter dans le panneau 
Source

Visualiser les 
diaporamas .RPres  
File > New  File > R 
Presentation

Répertoire 
de travail

Agrandir et réduire 
les panneaux

Glisser les 
bordures des 
panneaux

JHT

Curseurs d 
shared users

File > New Project

Taper ! pour voir 
l’historique de 
commande

Sélection multiple de curseurs/colonnes 
avec Alt + glisser la souris.

Documents et applications
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1 MISE EN PAGE Windows/Linux Mac
Focaliser sur l’éditeur Source Ctrl+1 Ctrl+1
Focaliser sur la Console Ctrl+2 Ctrl+2
Focaliser sur l’ Aide Ctrl+3 Ctrl+3
Voir l’Historique Ctrl+4 Ctrl+4
Voir les Fichiers Ctrl+5 Ctrl+5
Voir les Graphes Ctrl+6 Ctrl+6
Voir les Packages Ctrl+7 Ctrl+7
Voir l’Environment Ctrl+8 Ctrl+8
Voir le suivi de version Git/SVN Ctrl+9 Ctrl+9
Voir Build Ctrl+0 Ctrl+0

4 ECRIRE DU CODE Windows /Linux Mac
Autocomplétion Tab ou Ctrl+Espace Tab ou CmdEspace
Naviguer dans les choix !/" !/"
Accepter le choix Entrée, Tab, or # Entrée, Tab, or #
Rejeter le choix Echap Echap
Annuler Ctrl+Z Cmd+Z
Refaire Ctrl+Shift+Z Cmd+Shift+Z
Couper Ctrl+X Cmd+X
Copier Ctrl+C Cmd+C
Coller Ctrl+V Cmd+V
Tout sélectionner Ctrl+A Cmd+A
Supprimer la ligne Ctrl+D Cmd+D
Sélectionner Shift+[Flèche] Shift+[Flèche]
Sélectionner un mot Ctrl+Shift+ $/# Option+Shift+ $/#
Sélectionner jusqu’au début Alt+Shift+$ Cmd+Shift+$
Sélectionner jusqu’à la fin Alt+Shift+# Cmd+Shift+#
Sélectionner vers le haut/bas Shift+PageUp/Down Shift+PageUp/Down
Sélectionner Shift+Alt+!/" Cmd+Shift+!/"
Supprimer le mot à gauche Ctrl+Retour Ctrl+Opt+Retour
Supprimer le mot à droite   Option+Suppr
Supprimer jusqu’à la fin   Ctrl+K
Supprimer à partir du début   Option+Retour
Indenter Tab (au début) Tab (au début)
Aligner à gauche Shift+Tab Shift+Tab
Coller au-dessus du curseur Ctrl+U Ctrl+U
Coller en-dessous du curseur Ctrl+K Ctrl+K
Insert le texte copié Ctrl+Y Ctrl+Y
Insérer un  <- Alt+- Option+-
Insérer un  %>% Ctrl+Shift+M Cmd+Shift+M
Voir l’Aide de la fonction F1 F1
Voir le code source F2 F2
Nouveau document Ctrl+Shift+N Cmd+Shift+N
Nouveau document (Chrome) Ctrl+Alt+Shift+N Cmd+Shift+Alt+N
Ouvrir un document Ctrl+O Cmd+O
Sauver un document Ctrl+S Cmd+S
Fermer un document Ctrl+W Cmd+W
Fermer un document (Chrome) Ctrl+Alt+W Cmd+Option+W
Fermer tous les documents Ctrl+Shift+W Cmd+Shift+W
Extraire une fonction Ctrl+Alt+X Cmd+Option+X
Extraire une variables Ctrl+Alt+V Cmd+Option+V
Réindenter le code Ctrl+I Cmd+I
(Dé)Commenter le code Ctrl+Shift+C Cmd+Shift+C
Réagencer le commentaire Ctrl+Shift+/ Cmd+Shift+/
Formater la sélection Ctrl+Shift+A Cmd+Shift+A
Sélection entre accolades Ctrl+Shift+E Ctrl+Shift+E
Voir les diagnostics Ctrl+Shift+Alt+P Cmd+Shift+Alt+P
Transposer les  lettres   Ctrl+T
Déplacer la ligne en haut/bas Alt+!/" Option+!/"
Copier en Haut/Bas Shift+Alt+!/" Cmd+Option+!/"
Ajouter  curseur au-dessus Ctrl+Alt+Haut Ctrl+Alt+ Haut
Ajouter curseur en-dessous Ctrl+Alt+Bas Ctrl+Alt+Bas
Déplacer le curseur actif (haut) Ctrl+Alt+Shift+Haut Ctrl+Alt+Shift+Haut
Déplacer le curseur actif (bas) Ctrl+Alt+Shift+Bas Ctrl+Alt+Shift+Bas
Rechercher/Remplacer Ctrl+F Cmd+F
Rechercher la sélection Ctrl+F3 Cmd+E
Remplacer et rechercher Ctrl+Shift+J Cmd+Shift+J

2 EXECUTER DU CODE Windows/Linux Mac
Rappeler la commande Ctrl+! Cmd+!
Naviguer dans l’historique !/" !/"
Déplacer le curseur au début Home Cmd+$
Déplacer le curseur à la fin Fin Cmd+ #
Changer le répertoire courant Ctrl+Shift+H Ctrl+Shift+H
Interrompre l’exécution Echap Echap
Nettoyer la console Ctrl+L Ctrl+L
Quitter la session (version bureau) Ctrl+Q Cmd+Q
Redémarrer la session Ctrl+Shift+F10 Cmd+Shift+F10
Exécuter la ligne/sélection Ctrl+Entrée Cmd+Entrée
Exécuter la sélection (curseur fixé) Alt+Entrée Option+Entrée
Exécuter jusqu’à la fin Ctrl+Alt+E Cmd+Option+E
Exécuter la fonction courante Ctrl+Alt+F Cmd+Option+F
Source un fichier Ctrl+Shift+O Cmd+Shift+O
Source le fichier courant Ctrl+Shift+S Cmd+Shift+S
Source avec écho Ctrl+Shift+Entrée Cmd+Shift+Entrée

RStudio® est une marque déposée par  RStudio, Inc.  •  CC BY RStudio •  info@rstudio.com  •  844-448-1212 • rstudio.com En savoir plus :  support.rstudio.com  •  RStudio IDE  0.99.832  •  Mise à jour : 01/16Plus d’aide-mémoires sur http://www.rstudio.com/resources/cheatsheets/

3 NAVIGUER DANS LE CODE Windows /Linux Mac
Aller au fichier/fonction Ctrl+. Ctrl+.
Plier la sélection Alt+L Cmd+Option+L
Déplier la sélection Shift+Alt+L Cmd+Shift+Option

+LTout plier Alt+O Cmd+Option+O
Tout déplier Shift+Alt+O Cmd+Shift+Option

+OAller à la ligne Shift+Alt+G Cmd+Shift+Option
+GAller à Shift+Alt+J Cmd+Shift+Option
+JChanger d’onglet Ctrl+Shift+. Ctrl+Shift+.

Onglet précédent Ctrl+F11 Ctrl+F11
Onglet suivant Ctrl+F12 Ctrl+F12
Premier onglet Ctrl+Shift+F11 Ctrl+Shift+F11
Dernier onglet Ctrl+Shift+F12 Ctrl+Shift+F12
Naviguer en avant Ctrl+F9 Cmd+F9
Naviguer en arrière Ctrl+F10 Cmd+F10
Aller aux accolades Ctrl+P Ctrl+P
Sélection inter-accolades Ctrl+Shift+Alt+E Ctrl+Shift+Alt+E
Chercher la sélection Ctrl+F3 Cmd+E
Chercher dans les fichiers Ctrl+Shift+F Cmd+Shift+F
Chercher dans le suivant Win: F3, Linux: Ctrl+G Cmd+G
Chercher dans le précédent W: Shift+F3, L: Ctrl+Shift+G Cmd+Shift+G
Aller au « mot » Ctrl+ $/# Option+ $/#
Aller au début/fin Ctrl+!/" Cmd+!/"

5 DEBUGGER DU CODE Windows/Linux Mac
Activer les points d’arrêts Shift+F9 Shift+F9
Exécuter la prochaine ligne F10 F10
Entrer dans la fonction Shift+F4 Shift+F4
Terminer la fonction/boucle Shift+F6 Shift+F6
Continuer Shift+F5 Shift+F5
Arrêter le  mode « Debug » Shift+F8 Shift+F8

6 SUIVI DE VERSION Windows/Linux Mac
Voir le diff Ctrl+Alt+D Ctrl+Option+D
Valider les changements (commit) Ctrl+Alt+M Ctrl+Option+M
Faire défiler le diff Ctrl+!/" Ctrl+!/"
Indexer/Désindexer (Git) Espace Espace
Indexer/Désindexer et suivant Entrée Entrée

7 FAIRE DES PACKAGES Windows/Linux Mac
Développer et charger Ctrl+Shift+B Cmd+Shift+B
Tout charger (devtools) Ctrl+Shift+L Cmd+Shift+L
Tester le Package (Desktop) Ctrl+Shift+T Cmd+Shift+T
Test le Package (Web) Ctrl+Alt+F7 Cmd+Alt+F7
Vérifier le Package Ctrl+Shift+E Cmd+Shift+E
Documenter le Package Ctrl+Shift+D Cmd+Shift+D

8 DOCUMENTS ET APPS Windows/Linux Mac
Aperçu HTML (Markdown, etc.) Ctrl+Shift+K Cmd+Shift+K
Knit le document (knitr) Ctrl+Shift+K Cmd+Shift+K
Compiler un Notebook (bloc-notes) Ctrl+Shift+K Cmd+Shift+K
Compiler un PDF (TeX and Sweave) Ctrl+Shift+K Cmd+Shift+K
Insérer un chunk (Sweave and Knitr) Ctrl+Alt+I Cmd+Option+I
Insérer une section de code Ctrl+Shift+R Cmd+Shift+R
Réexécuter la sélection Ctrl+Shift+P Cmd+Shift+P
Exécuter le document courant Ctrl+Alt+R Cmd+Option+R
Exécuter du début à la ligne Ctrl+Alt+B Cmd+Option+B
Exécuter la section de code Ctrl+Alt+T Cmd+Option+T
Exécuter le code Sweave/Rmd Ctrl+Alt+P Cmd+Option+P
Exécuter le chunk courant Ctrl+Alt+C Cmd+Option+C
Exécuter le prochain chunk Ctrl+Alt+N Cmd+Option+N
Synchroniser Editeur et PDF Ctrl+F8 Cmd+F8

Précédent graphe Ctrl+Alt+F11 Cmd+Option+F11
Prochain graphe Ctrl+Alt+F12 Cmd+Option+F12

Voir les raccourcis clavier Alt+Shift+K Option+Shift+K

Pourquoi RStudio Server Pro?
Réaliser tout ce qu’il est possible de faire sur un serveur open source 
avec une licence commerciale, un support et plus encore : 

• éditer les projets simultanément aux autres utilisateurs 
• basculer facilement d’une version R à une autre 
• ouvrir et exécuter plusieurs sessions R simultanément 
• voir les usages des utilisateurs sur le serveur 
• calibrer les ressources pour améliorer les performances 
• intégrer les pratiques d’ authentification, autorisation et d’audit 

Télécharger une version d’essai de 45 jours sur :  
www.rstudio.com/products/rstudio-server-pro/

Traduit par  Diane BELDAME - diane@thinkr.fr - http://www.thinkr.fr
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